Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 21, 2019 - 01:24 UTC
Identified
Cloudflare is investigating delays of over 25 minutes in updates to DNS records. This delay also affects provisioning new Argo Tunnel instances by over 25 minutes.

DNS resolution and established Argo Tunnels are not impacted.
Posted about 1 month ago. Sep 21, 2019 - 01:08 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).