Cloudflare System Status

Cloudflare Dashboard: Issues managing memberships

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 10:45 UTC

Identified

We have identified the issue and are working on a fix.
Posted Nov 05, 2025 - 10:32 UTC

Investigating

Cloudflare is investigating minor issues with Cloudflare Dashboard. Some customers are unable to configure account memberships from the dashboard.

These issues do not affect the serving of cached files via the Cloudflare CDN or other security features at the Cloudflare Edge.

Customers using the Dashboard / Cloudflare APIs are impacted as requests might fail and/or errors may be displayed.
Posted Nov 05, 2025 - 08:53 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).