Cloudflare System Status

Workers Logs Issues

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted May 22, 2025 - 16:50 UTC

Monitoring

The cause of this issue was identified and a fix was implemented. We are currently monitoring the results.
Posted May 22, 2025 - 16:40 UTC

Investigating

Cloudflare is investigating an issue impacting Workers Logs. Users may experience errors trying to view logs at this time. More updates to follow shortly.
Posted May 22, 2025 - 16:28 UTC
This incident affected: Cloudflare Sites and Services (Workers Observability).