Cloudflare System Status

HTTP 520 errors
Incident Report for Cloudflare
Resolved
This issue has been resolved.
Posted about 1 month ago. Sep 18, 2019 - 23:00 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted about 1 month ago. Sep 18, 2019 - 22:50 UTC
Investigating
Some customers may be experiencing 520 errors while accessing sites on Cloudflare.
Posted about 1 month ago. Sep 18, 2019 - 19:45 UTC