Cloudflare System Status

Network Performance Issues in Iraq

Incident Report for Cloudflare

Resolved

An effective fix for this issue was applied and this incident is now resolved.
Posted Nov 13, 2025 - 18:26 UTC

Investigating

Cloudflare is aware of, and investigating an issue which impacts customers in Iraq.
Posted Nov 13, 2025 - 18:17 UTC
This incident affected: Cloudflare Sites and Services (D1, Durable Objects, Queues, R2).