Cloudflare System Status

Registrar Operations Failing
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Nov 29, 2022 - 22:41 UTC
Investigating
Cloudflare is currently investigating issues with registrar operations for .io and other TLDs failing.
Posted Nov 29, 2022 - 20:24 UTC
This incident affected: Cloudflare Sites and Services (Registrar).