Cloudflare System Status

Network Performance Issues
Incident Report for Cloudflare
Resolved
Cloudflare experienced a global traffic disruption between 19:32 - 19:38 UTC. The cause has been identified as an event in the Internet routing table which impacted multiple Internet providers. We are investigating the root cause with the involved third party provider.
Posted Apr 01, 2020 - 21:00 UTC
Update
The issue has stabilized and there is no current impact at this moment.
Posted Apr 01, 2020 - 20:12 UTC
Identified
The issue has been identified.
Posted Apr 01, 2020 - 20:04 UTC
Investigating
Cloudflare is investigating issues with network performance.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly
Posted Apr 01, 2020 - 19:49 UTC