Cloudflare System Status

During domain transfers, some customers may be unable to verify their email address due to an invalid verification link
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 18, 2023 - 11:34 UTC
Update
We are continuing to monitor for any further issues.
Posted May 18, 2023 - 11:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2023 - 09:28 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 18, 2023 - 08:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 18, 2023 - 06:55 UTC
Investigating
Cloudflare is investigating an issue where some users are unable to verify their email address due to an invalid verification link during domain transfers.
Posted May 18, 2023 - 05:37 UTC
This incident affected: Cloudflare Sites and Services (Registrar).