Cloudflare System Status

SSL Certificate Provisioning Delays

Incident Report for Cloudflare

Identified

We have identified a constraint in the Certificate Authority issuance pipeline that consequently is hindering our ability to validate a fair amount of certificates. We are awaiting further developments from Google Trust Services.
Posted Apr 24, 2025 - 08:36 UTC

Update

We are continuing to investigate this issue.
Posted Apr 23, 2025 - 10:27 UTC

Investigating

Cloudflare is investigating delays in provisioning SSL certificates with Google Trust Services. SSL certificates already in production remain unaffected and are operating normally.
Posted Apr 23, 2025 - 09:12 UTC
This incident affects: Cloudflare Sites and Services (SSL Certificate Provisioning).