Cloudflare System Status

Cloudflare Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 10, 2020 - 00:27 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted Jun 09, 2020 - 23:39 UTC
Identified
Cloudflare has identified the issue and is implementing a fix.

We will update the status once we implement the fix.
Posted Jun 09, 2020 - 23:35 UTC
Investigating
Cloudflare is experiencing problems in processing changes through our billing subscription service. All other services are operating normally.

We will provide an update once billing subscription services return to normal.
Posted Jun 09, 2020 - 17:54 UTC
This incident affected: Cloudflare Sites and Services (Billing).