Cloudflare System Status

Cloudflare Workers Cron Triggers Impacted
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted Mar 18, 2022 - 01:24 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted Mar 18, 2022 - 01:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2022 - 23:51 UTC
Investigating
We are currently experience an issue with Workers Cron Triggers executing at the edge. We are currently investigating the root cause.
Posted Mar 17, 2022 - 23:32 UTC
This incident affected: Cloudflare Sites and Services (Workers).