Cloudflare System Status

SSL Certificate Provisioning Delays (Custom SSL only)
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 05, 2019 - 21:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Jun 05, 2019 - 20:51 UTC
Investigating
Cloudflare is investigating delays in provisioning custom SSL certificates using Legacy support only.

SSL certificates already in production remain unaffected and are operating normally.
Posted 2 months ago. Jun 05, 2019 - 18:33 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).