Cloudflare System Status

Issues passing Challenge Pages and Turnstile
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Feb 23, 2024 - 01:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2024 - 01:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 23, 2024 - 01:19 UTC
Investigating
Cloudflare has identified an issue where some visitors may experience issues passing Challenge Pages and Turnstile challenges.

We are working to mitigate this problem. More updates to follow shortly.
Posted Feb 23, 2024 - 00:48 UTC
This incident affected: Cloudflare Sites and Services (Challenge Platform, Turnstile).