Cloudflare System Status

Workers and Pages builds, Pages API unavailable

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 21:48 UTC

Monitoring

Builds have been stable since 21:12 UTC and we are monitoring the fix.
Posted Mar 02, 2026 - 21:32 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2026 - 21:16 UTC

Update

We are continuing to investigate this issue.
Posted Mar 02, 2026 - 20:54 UTC

Investigating

Cloudflare is aware of and investigating an issue impacting Workers and Pages builds, and the Cloudflare Pages API starting at 20:22 UTC. Customers may experience 5xx errors, and builds may fail to start or complete.

We are actively working to understand and mitigate the impact.
Posted Mar 02, 2026 - 20:45 UTC
This incident affected: Cloudflare Sites and Services (Pages, Workers Builds).