Cloudflare System Status

Cloudflare Pages - Custom Domain Management Degraded

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 23:32 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 27, 2026 - 22:37 UTC

Investigating

Cloudflare has identified an issue impacting the API for managing and adding custom domains in Cloudflare Pages. Customers may experience failures or errors when attempting to add or manage custom domains via the Pages API or dashboard.

Additionally, the SSL for SaaS Custom Hostnames API is experiencing high latency and intermittent errors, which may be contributing to the impact on custom domain management.

Deployed Workers and Pages projects continue to serve traffic normally. Only custom domain management is affected.
Posted Mar 27, 2026 - 22:36 UTC
This incident affected: Cloudflare Sites and Services (Pages).