Cloudflare System Status

Cloudflare Billing Issues
Incident Report for Cloudflare
Resolved
The Billing issue was identified and has been resolved.
Posted Mar 06, 2021 - 17:52 UTC
Identified
The Billing issue has been identified and resolution is in progress.
Posted Mar 06, 2021 - 17:16 UTC
Investigating
Cloudflare is experiencing problems in processing changes through our billing subscription service with credit-card or paypal. Purchasing might be affected with these payment method, all other services are operating normally.

We will provide an update once billing subscription services return to normal.
Posted Mar 06, 2021 - 16:09 UTC
This incident affected: Cloudflare Sites and Services (Billing).