Cloudflare System Status

Subscription Outage
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 22, 2019 - 01:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Apr 22, 2019 - 01:11 UTC
Investigating
Cloudflare is experiencing problems with processing subscription updates.
This impacts new subscriptions and changes to existing subscriptions.

We are currently working on a resolution.
Posted about 1 month ago. Apr 22, 2019 - 00:58 UTC
This incident affected: Cloudflare Sites and Services (Billing).