Cloudflare System Status

Cloudflare for Teams sign up issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 20, 2020 - 03:16 UTC
Identified
Cloudflare is investigating issues with users unable to sign up for Cloudflare for Teams.

Customers trying to sign up Cloudflare for Teams are impacted as requests might fail and/or errors may be displayed. Non-teams customers are unaffected. The engineering team is implementing a fix.
Posted Mar 20, 2020 - 02:41 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Teams Dashboard).