Cloudflare System Status

HTTP timeouts in European locations
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 18, 2022 - 13:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2022 - 11:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 18, 2022 - 10:33 UTC
Investigating
Cloudflare is aware of, and investigating an issue which potentially impacts some customers causing HTTP connection timeouts on European locations. Further detail will be provided as more information becomes available.
Posted Mar 18, 2022 - 10:21 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache).