Cloudflare System Status

Network issues in Buenos Aires
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 15, 2015 - 08:42 UTC
Investigating
We are currently investigating this issue.
Posted Jun 12, 2015 - 17:01 UTC
This incident affected: Latin America & the Caribbean (Buenos Aires, Argentina - (EZE)).