Cloudflare System Status

Cloudflare services functioning normally in Spain, Portugal, Andorra, and France

Incident Report for Cloudflare

Monitoring

We have routed some traffic out of this region to ensure our services continue to function normally. We will continue to monitor this situation and will provide further updates as it develops.
Posted Apr 28, 2025 - 16:19 UTC

Investigating

Cloudflare is aware of the widespread power issues in Spain, Portugal, Andorra, and France. All Cloudflare services are online and functioning normally in the region. We will continue to monitor the situation and take appropriate action.
Posted Apr 28, 2025 - 14:18 UTC