Cloudflare System Status

Customer impacting issue related to R2 Storage's CopyObject API
Incident Report for Cloudflare
Resolved
We identified a scenario where Copying MultiPart Uploads can have unexpected behavior. After temporarily disabling CopyObject for MultiPart uploads, the root cause for this issue has been fully addressed, and the CopyObject endpoint has been re-enabled for MultiPart objects.
Posted Sep 27, 2022 - 22:57 UTC
Identified
Cloudflare has identified the issue and is implementing a fix. We will update the status once we implement the fix.
Posted Sep 27, 2022 - 22:44 UTC
Investigating
We're currently investigating a bug of R2 Storage API with the interaction of CopyObject and objects created via multipart uploads.
Posted Sep 27, 2022 - 16:53 UTC
This incident affected: Cloudflare Sites and Services (R2).