Cloudflare System Status

Elevated 503s returned in Milan for Cache API

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 07, 2025 - 19:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2025 - 19:42 UTC

Investigating

Elevated 503 errors for Cache API PUT requests in Milan, IT. Non-Cache API requests are not impacted.
Posted May 07, 2025 - 19:11 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache) and Europe (Milan, Italy - (MXP)).