Cloudflare System Status

Network Performance Issues in Ashburn and North America
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 08:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2020 - 03:34 UTC
Investigating
Cloudflare is investigating issues with network performance in Ashburn and North America.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly
Posted Apr 24, 2020 - 02:57 UTC
This incident affected: North America (Ashburn, VA, United States - (IAD)).