Cloudflare System Status

Page Rules and Cloudflare Universal SSL certificates delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and Page Rules/ Cloudflare Universal SSL certificates services have resumed normal operation.
Posted 2 months ago. May 08, 2019 - 21:33 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted 2 months ago. May 08, 2019 - 20:46 UTC
Update
We are continuing to investigate this issue.
Posted 2 months ago. May 08, 2019 - 20:13 UTC
Investigating
Cloudflare is investigating Page Rules and Cloudflare Universal SSL certificates delays. This only affects Page Rule updates and changes as well as new Certificates orders.
Posted 2 months ago. May 08, 2019 - 18:52 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).