Cloudflare System Status

Pages API and builds unavailable

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 22:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2026 - 21:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 09, 2026 - 21:36 UTC

Identified

Cloudflare is aware of and investigating an issue impacting the Cloudflare Pages API and Pages builds.

Customers may be experiencing 5xx errors and builds may be failing to start or complete.
We are working to understand and mitigate the impact
Posted Mar 09, 2026 - 21:35 UTC
This incident affected: Cloudflare Sites and Services (Pages).