Cloudflare System Status

Network performance issues in the Hyderabad (HYD) region

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 08:59 UTC

Monitoring

Some customers may have experienced network performance issues for traffic landing at the Hyderabad (HYD) datacenter. The issue has been identified and fixed.
Posted Apr 16, 2026 - 08:51 UTC