Cloudflare System Status

Intermittent Slow Cache Responses

Incident Report for Cloudflare

Identified

The cause of this issue has been identified and a fix is being implemented.
Posted Jun 13, 2026 - 23:43 UTC

Investigating

We are currently investigating an issue where a small number of requests are experiencing higher than expected latency on cache HITs.
Posted Jun 13, 2026 - 23:22 UTC
This incident affects: Cloudflare Sites and Services (CDN/Cache).