Cloudflare System Status

Configuration Settings Change Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 07, 2022 - 03:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2022 - 02:42 UTC
Investigating
Cloudflare is experiencing delays in updating customer settings. This includes general changes to Cloudflare settings, Page Rules, Firewall, DNS, and SSL certificate deployment. This does not impact existing settings already in production.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jul 07, 2022 - 02:31 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Dashboard, Cloudflare API, DNS Updates).