Cloudflare System Status

Email Delivery Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 14, 2020 - 16:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2020 - 15:58 UTC
Investigating
Cloudflare is investigating delays of up to 2 hours in our ability to send emails. This includes password reset emails, MFA token emails and others. We are working to resolve the issue. More updates to follow shortly.
Posted Apr 14, 2020 - 15:29 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Dashboard).