Cloudflare System Status

Increase latency on R2 operations on WNAM buckets

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 22:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2025 - 22:02 UTC

Investigating

We are currently investigating high long-tail latency on some R2 requests with buckets in the WNAM region. Impacted buckets will see increased latency on PutObject operations. Impacting Stream Live broadcasts, R2. Stream on-demand and media transformations are not affected.
Posted Nov 07, 2025 - 20:40 UTC
This incident affected: Cloudflare Sites and Services (R2, Stream).