Cloudflare System Status

Increased CDN Latency

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted Sep 04, 2025 - 18:36 UTC

Monitoring

We have identified and applied a fix for an issue resulting in increased request latency for our MCI (Kansas City, US), SKG (Thessaloniki, GR), LIM (Lima, PE), LYS (Lyon, FR) and PDX (Portland, US) facilities. We are currently monitoring the results.
Posted Sep 04, 2025 - 17:55 UTC
This incident affected: North America (Kansas City, MO, United States - (MCI), Portland, OR, United States - (PDX)), Latin America & the Caribbean (Lima, Peru - (LIM)), and Europe (Thessaloniki, Greece - (SKG), Lyon, France - (LYS)).