Cloudflare System Status

Cloudflare Zero Trust Dashboard
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 25, 2022 - 04:44 UTC
Investigating
Cloudflare is investigating issues with Cloudflare Zero Trust Dashboard, customer may having issues with some of the functionalities in Zero Trust dashboard.
Posted Mar 25, 2022 - 03:52 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Zero Trust Dashboard).