Cloudflare System Status

DNS Request Latency
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 28, 2020 - 17:10 UTC
Update
We are continuing to investigate this issue.
Posted Oct 28, 2020 - 17:01 UTC
Investigating
Cloudflare is investigating slowness in DNS requests in some locations.
Posted Oct 28, 2020 - 16:02 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Authoritative DNS).