Cloudflare System Status

Payment processing issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 15, 2020 - 15:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2020 - 15:18 UTC
Investigating
Cloudflare is investigating issues with updating payment methods and processing payments. Customers may observe an error when performing these actions.
Posted May 15, 2020 - 14:05 UTC
This incident affected: Cloudflare Sites and Services (Billing).