Cloudflare System Status

Cloudflare Zero Trust Dashboard issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 25, 2022 - 10:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 25, 2022 - 09:51 UTC
Investigating
Cloudflare is investigating issues with the Cloudflare Zero Trust dashboard UI. Existing rules and connections are not impacted.
Posted May 25, 2022 - 09:37 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Zero Trust Dashboard).