Cloudflare System Status

Investigating network congestion
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 20, 2015 - 13:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2015 - 11:22 UTC
Update
We have observed upstream network provider issues resulting in connectivity issues to multiple CloudFlare locations in the US and Europe.
Posted Mar 20, 2015 - 10:15 UTC
Investigating
We're receiving reports of network congestion in San Jose.

Investigating.
Posted Mar 20, 2015 - 10:07 UTC
This incident affected: North America (Dallas, TX, United States - (DFW), Los Angeles, CA, United States - (LAX), San Jose, CA, United States - (SJC)).