Cloudflare System Status

CDN Single-File Cache Purge Delays In Some Colos

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted Oct 31, 2025 - 19:48 UTC

Monitoring

A fix has been implemented and we are currently monitoring the results.
Posted Oct 31, 2025 - 19:16 UTC

Identified

Cloudflare single-file cache purging called via the API is running behind in a subset of colos. As a result some customers may be observing stale content for requests to those facilities.

We are working to eliminate this issue. Until it is resolved, use the Purge All feature, which may cause a surge in traffic to your origin server.
Posted Oct 31, 2025 - 18:51 UTC
This incident affected: Asia (Bangalore, India - (BLR), Kuala Lumpur, Malaysia - (KUL)), North America (Detroit, MI, United States - (DTW), Salt Lake City, UT, United States - (SLC), San Antonio, United States - (SAT)), Cloudflare Sites and Services (CDN Cache Purge), and Europe (Lisbon, Portugal - (LIS)).