Cloudflare System Status

Load Balancing Health Monitor Delays

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 00:14 UTC

Monitoring

We have identified and implemented a fix for this issue. We are currently monitoring the results.
Posted Oct 20, 2025 - 22:54 UTC

Investigating

We are investigating an issue where processing of Load Balancing health events is degraded, leading to delays in notifications and analytics regarding Load Balancing health monitoring, as well as delays in steering decisions for some customers.
Posted Oct 20, 2025 - 21:29 UTC
This incident affected: Cloudflare Sites and Services (Load Balancing and Monitoring).