Cloudflare System Status

Resolution Issues for .AL Domains

Incident Report for Cloudflare

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2026 - 17:25 UTC

Update

Cloudflare is temporarily disabling DNSSEC validation for .AL domains on 1.1.1.1 resolver (as per RFC 7646) in order to allow .AL names to continue to resolve. DNSSEC validation will be re-enabled when the signing problems are known to have been resolved.

See RFC 7646 for more details:
https://datatracker.ietf.org/doc/html/rfc7646
Posted Jul 03, 2026 - 17:02 UTC

Identified

We are observing issues with authoritative resolution for the .AL TLD because of DNSSEC issues at the TLD.
Posted Jul 03, 2026 - 16:48 UTC
This incident affects: Cloudflare Sites and Services (Recursive DNS).