Cloudflare System Status

Cloudflare pages build failures

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 00:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2026 - 21:44 UTC

Investigating

Some Cloudflare Pages customers may be experiencing failures. Affected customers can retry their builds through the Dashboard.
Posted Jun 18, 2026 - 20:52 UTC
This incident affected: Cloudflare Sites and Services (Pages).