Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 12, 2019 - 16:58 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.
Posted 2 months ago. Mar 12, 2019 - 16:39 UTC
Investigating
Cloudflare is investigating delays of up to 60 minutes in updates to DNS records. These delays only affect record changes and updates.

DNS resolution is operating normally.
Posted 2 months ago. Mar 12, 2019 - 15:15 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).