Cloudflare System Status

Elevated Level of Timeouts for a Limited Number of Customers
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted Aug 28, 2020 - 16:11 UTC
Update
We are continuing to investigate this issue.
Posted Aug 28, 2020 - 15:44 UTC
Update
We are investigating an elevated number of 522 errors from around 09:00 UTC. So far this appears to be impacting specific customers in some but not all locations. We are working on identifying the possible root cause for this increase and determining the exact locations that are affected.
Posted Aug 28, 2020 - 15:01 UTC
Investigating
Cloudflare is aware of, and investigating an issue which potentially impacts multiple customers. Further detail will be provided as more information becomes available.
Posted Aug 28, 2020 - 14:50 UTC