Cloudflare System Status

Workers Cron Triggers Past Events not displaying
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 23:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2020 - 21:21 UTC
Update
The issue has been identified and a fix is being implemented. This is no longer affecting Workers Analytics performance and is only affecting Workers Cron Triggers Past Events.
Posted Sep 28, 2020 - 18:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 28, 2020 - 18:08 UTC
Update
We are continuing to investigate this issue.
Posted Sep 28, 2020 - 17:46 UTC
Investigating
We are currently observing degraded Workers Analytics performance and when viewing Workers Cron Triggers Past Events. This only affects Analytics and does not impact successful Cloudflare Workers or Workers Cron Triggers execution.
Posted Sep 28, 2020 - 17:45 UTC
This incident affected: Cloudflare Sites and Services (Analytics).