This issue has been resolved and services have returned to normal.
Posted Dec 21, 2017 - 14:45 UTC
Monitoring
The fix is in place and are currently monitoring the results.
We will update once we have confirmed it is totally resolved.
Posted Dec 21, 2017 - 13:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Delays are now at 33 minutes and dropping.
We will update once we have confirmed there are no more delays.
Posted Dec 21, 2017 - 12:35 UTC
Investigating
Cloudflare is experiencing delays globally of up to 90 minutes in updating and changing customer settings.
This includes general Cloudflare settings, page rules, firewall and DNS changes. Delivery of content is not impacted, only updates and changes are delayed.
Posted Dec 21, 2017 - 11:55 UTC
This incident affected: Cloudflare Sites and Services (API, Dashboard).