Cloudflare System Status

Missing PII information display for Cloudflare One Super Admins

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 16:37 UTC

Investigating

The Cloudflare One dashboard is not showing PII information to Super Admins on Logging side panel details.
Posted Mar 25, 2026 - 16:13 UTC
This incident affected: Cloudflare Sites and Services (Zero Trust Dashboard).