Cloudflare System Status

Network Performance Issues in Madrid, Algiers, Oran
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted Sep 13, 2023 - 00:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2023 - 20:05 UTC
Identified
We have observed increased latency for requests to our facilities in Madrid, Algiers, and Oran and are currently working on a resolution for this issue.
Posted Sep 12, 2023 - 19:48 UTC
This incident affected: Africa (Algiers, Algeria - (ALG), Oran, Algeria - (ORN)) and Europe (Madrid, Spain - (MAD)).