Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 15, 2020 - 15:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results. The current delay is below 30 minutes.
Posted Apr 15, 2020 - 15:01 UTC
Identified
The issue has been identified and a fix is being implemented.

The current delay is up to 1 hour for updates to DNS records for free zones. No other services are affected.
Posted Apr 15, 2020 - 14:11 UTC
Investigating
Cloudflare is investigating delays of up to 1 hours for updates to DNS records. This delay also affects provisioning SSL certificates, new Argo Tunnel instances and the reconnection of Argo Tunnels that use Cloudflare's load balancer

DNS resolution, existing SSL certificates, and established Argo Tunnels are not impacted. More updates to follow shortly.
Posted Apr 15, 2020 - 12:01 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).