Cloudflare System Status

Cloudflare Pages GitLab Repository Connection Issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Sep 19, 2025 - 22:20 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 19, 2025 - 20:15 UTC

Investigating

Cloudflare is investigating issues with GitLab repository connections for Pages projects. Customers with multiple GitLab accounts may be unable to see their repositories when creating new Pages projects. Existing Pages sites are not affected. We are working to fix this problem. More updates to follow shortly.
Posted Sep 19, 2025 - 20:10 UTC
This incident affected: Cloudflare Sites and Services (Pages).