Cloudflare System Status

Network Performance Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 10, 2019 - 14:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Jun 10, 2019 - 14:36 UTC
Investigating
Cloudflare is observing network performance issues resulting in customers seeing "Connection timeout" errors while requesting sites on the IP range 198.41.214.0/23
Posted 2 months ago. Jun 10, 2019 - 14:14 UTC